マカフィー・ストア
Welcome Guest 
メインメニュー
Googleアナリティクス
  • 動画を携帯向けに変換するには、FFmpegを使う場合、MP4boxが必要らしい ;(
    という訳でインストール。

確認環境 anchor.png

  1. CentOS 5.7 (x86/32ビット版)
Page Top

インストール anchor.png

  1. 依存ライブラリをインストール。
    1. 一応、エンコード類を入れるが、MP4boxでは、コーデック関連は使用しない(ですむはず)&現物インストール時に依存関係が出てしまうが、念の為。
    2. js-devel/libjpeg-devel/libpng-devel/libmad-devel/xvidcore-devel/jack-audio-connection-kit-develを依存関係含め、インストール。
      1. libjpeg-devel/libpng-develは標準リポジトリ。
      2. jack-audio-connection-kit-develは、EPEL
      3. それ以外はRPMforge

        # yum install js-devel libjpeg-devel libpng-devel libmad-devel xvidcore-devel jack-audio-connection-kit-devel

  2. 本家からダウンロードするのが良いんだろうけど、なかなかうまくパッケージが作れなかったので、Rpmfind(正式名称わからず [worried] )と並んでお世話になっているRPM Search(正式名称わからず [worried] )でgpacを検索して、依存関係を含めダウンロード&インストール。

    # wget ftp://mirror.switch.ch/pool/3/mirror/rpmfusion/free/el/updates/testing/5/i386/gpac-0.4.5-0.7.20080217cvs.el5.i386.rpm \
    ftp://mirror.switch.ch/pool/3/mirror/rpmfusion/free/el/updates/testing/5/i386/gpac-libs-0.4.5-0.7.20080217cvs.el5.i386.rpm

    1. freeglut-develが依存関係で出てくるのでインストール。

      # yum install freeglut-devel

    2. ダウンロードしたパッケージをインストール。
      1. 依存関係が出てインストールできない(「1.」をRpm Search内のパッケージで賄えばでないはず)が、可能な限り、yumでメンテしたい&コーデック関連なので無視してインストール。

        # rpm -Uvh --nodeps gpac-*.rpm

  3. インストール完了 :hammer:

Front page   Freeze Diff Backup Copy Rename ReloadPrint View   New Page Page list Search Recent changes   Help   RSS of recent changes (RSS 1.0) RSS of recent changes (RSS 2.0) RSS of recent changes (RSS Atom) Powered by xpWiki
Counter: 3348, today: 5, yesterday: 2
Princeps date: 2012-08-07 (Tue) 10:49:40
Last-modified: 2012-08-07 (Tue) 10:49:40 (JST) (2660d) by mugi
XOOPS Cube PROJECT
© 2011-2014 by 麦